请选择 进入手机版 | 继续访问电脑版

forum.gl-inet.cn

 找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 活动 交友 discuz
    楼主: 萝卜大侠

    【01.29更新】怎样快速编译出带glinet页面的固件

      [复制链接]

    6

    主题

    110

    帖子

    630

    积分

    高级会员

    Rank: 4

    积分
    630
    发表于 2022-7-15 19:43:40 | 显示全部楼层
    本帖最后由 7918 于 2022-7-15 20:27 编辑

    按照教程编译4x的固件,,几天前已经编译过,今天看有升级,就从头开始操作了一遍,保证和成功那次一样的配置(只加了个出国深造),但是报错了
    回复

    使用道具 举报

    1

    主题

    19

    帖子

    103

    积分

    注册会员

    Rank: 2

    积分
    103
    发表于 2022-7-15 11:13:46 | 显示全部楼层
    萝卜大侠 发表于 2022-7-15 09:35
    将你前面执行的命令贴一下,这种情况肯定是前面就报错了,你没注意到

    在运行 ./scripts/gen_config.py target_wlan_ap-gl-axt1800-5-4 glinet_depends 时候就报错了

    RNING: Makefile 'package/utils/policycoreutils/Makefile' has a build dependency on 'libpam', which does not exist
    WARNING: Makefile 'package/feeds/ipq807x/qca-ssdk/Makefile' has a dependency on 'kmod-qca-rfs', which does not exist
    WARNING: Makefile 'package/system/uvol/Makefile' has a dependency on 'lvm2', which does not exist
    WARNING: Makefile 'package/utils/busybox/Makefile' has a dependency on 'libpam', which does not exist
    WARNING: Makefile 'package/utils/busybox/Makefile' has a dependency on 'libpam', which does not exist
    WARNING: Makefile 'package/utils/busybox/Makefile' has a build dependency on 'libpam', which does not exist
    WARNING: Makefile 'package/boot/kexec-tools/Makefile' has a dependency on 'liblzma', which does not exist
    WARNING: Makefile 'package/network/services/lldpd/Makefile' has a dependency on 'libnetsnmp', which does not exist
    WARNING: Makefile 'package/utils/policycoreutils/Makefile' has a dependency on 'libpam', which does not exist
    WARNING: Makefile 'package/utils/policycoreutils/Makefile' has a dependency on 'libpam', which does not exist
    WARNING: Makefile 'package/utils/policycoreutils/Makefile' has a build dependency on 'libpam', which does not exist
    WARNING: Makefile 'package/feeds/ipq807x/qca-ssdk/Makefile' has a dependency on 'kmod-qca-rfs', which does not exist
    WARNING: Makefile 'package/system/uvol/Makefile' has a dependency on 'lvm2', which does not exist

    onfiguration written to .config
    Running make defconfig
    Collecting package info: done
    Collecting target info: done
    WARNING: Makefile 'package/feeds/luci/luci-app-rosy-file-server/Makefile' has a dependency on 'rosy-file-server', which does not exist
    WARNING: Makefile 'package/feeds/ipq807x/qca-ssdk/Makefile' has a dependency on 'kmod-qca-rfs', which does not exist
    WARNING: Makefile 'package/system/uvol/Makefile' has a dependency on 'lvm2', which does not exist
    #






    # configuration written to .config
    回复

    使用道具 举报

    65

    主题

    1680

    帖子

    5997

    积分

    管理员

    Rank: 9Rank: 9Rank: 9

    积分
    5997

    官方人员

     楼主| 发表于 2022-7-15 09:35:54 | 显示全部楼层
    sonnycui 发表于 2022-7-15 07:01
    5.4 内核,AXT1800,到 make就报错了。

    WARNING: Makefile 'package/feeds/luci/luci-app-rosy-file-server ...

    将你前面执行的命令贴一下,这种情况肯定是前面就报错了,你没注意到
    回复

    使用道具 举报

    1

    主题

    19

    帖子

    103

    积分

    注册会员

    Rank: 2

    积分
    103
    发表于 2022-7-15 07:01:33 | 显示全部楼层
    5.4 内核,AXT1800,到 make就报错了。

    WARNING: Makefile 'package/feeds/luci/luci-app-rosy-file-server/Makefile' has a dependency on 'rosy-file-server', which does not exist
    WARNING: Makefile 'package/feeds/ipq807x/qca-ssdk/Makefile' has a dependency on 'kmod-qca-rfs', which does not exist
    WARNING: Makefile 'package/system/uvol/Makefile' has a dependency on 'lvm2', which does not exist
    #
    # configuration written to .config
    #
    #########################
    #########################
    #########################


    #########################
    #########################
    #########################

    root@sggc2:~/lede/gl-infra-builder/wlan-ap/openwrt# make mennuconfig
    WARNING: Makefile 'package/feeds/luci/luci-app-rosy-file-server/Makefile' has a dependency on 'rosy-file-server', which does not exist
    WARNING: Makefile 'package/feeds/ipq807x/qca-ssdk/Makefile' has a dependency on 'kmod-qca-rfs', which does not exist
    WARNING: Makefile 'package/system/uvol/Makefile' has a dependency on 'lvm2', which does not exist
    time: target/linux/prereq#0.06#0.01#0.08
    make[1] mennuconfig
    make -r mennuconfig: build failed. Please re-run make with -j1 V=s or V=sc for a higher verbosity level to see what's going on
    make: *** [/root/lede/gl-infra-builder/wlan-ap/openwrt/include/toplevel.mk:230: mennuconfig] Error 1
    root@sggc2:~/lede/gl-infra-builder/wlan-ap/openwrt#
    回复

    使用道具 举报

    65

    主题

    1680

    帖子

    5997

    积分

    管理员

    Rank: 9Rank: 9Rank: 9

    积分
    5997

    官方人员

     楼主| 发表于 2022-7-14 19:34:31 | 显示全部楼层
    ocake 发表于 2022-7-10 11:28
    感谢大大无私分享,使用原汁原味没添加减少的方法,成功编译AXT1800 5.4固件,过程出现下列依赖软件错误 ...

    警告可以忽略
    回复

    使用道具 举报

    65

    主题

    1680

    帖子

    5997

    积分

    管理员

    Rank: 9Rank: 9Rank: 9

    积分
    5997

    官方人员

     楼主| 发表于 2022-7-14 19:33:53 | 显示全部楼层
    ocake 发表于 2022-7-10 11:28
    感谢大大无私分享,使用原汁原味没添加减少的方法,成功编译AXT1800 5.4固件,过程出现下列依赖软件错误 ...

    无法uboot升级的问题已经解决了
    回复

    使用道具 举报

    1

    主题

    19

    帖子

    103

    积分

    注册会员

    Rank: 2

    积分
    103
    发表于 2022-7-14 17:25:20 | 显示全部楼层
    ocake 发表于 2022-7-10 11:28
    感谢大大无私分享,使用原汁原味没添加减少的方法,成功编译AXT1800 5.4固件,过程出现下列依赖软件错误 ...

    是的 AXT,5.4 我也遇到这个问题
    回复

    使用道具 举报

    0

    主题

    6

    帖子

    54

    积分

    注册会员

    Rank: 2

    积分
    54
    发表于 2022-7-14 13:27:28 | 显示全部楼层
    支持支持!
    回复

    使用道具 举报

    5

    主题

    23

    帖子

    173

    积分

    注册会员

    Rank: 2

    积分
    173
    QQ
    发表于 2022-7-12 18:42:20 | 显示全部楼层
    支持支持!
    回复

    使用道具 举报

    17

    主题

    260

    帖子

    980

    积分

    高级会员

    Rank: 4

    积分
    980
    发表于 2022-7-10 16:48:27 | 显示全部楼层
    7918 发表于 2022-7-10 16:27
    多谢多谢,搞死我了,,,,,添加app和协议这些是自动添加的吗 ,,只添加这些不用再修改别的了吧,, ...

    生成配置完先看下有没有依赖缺失等等的问题,解决后编译过程中出问题了需要进行一些调整
    回复

    使用道具 举报

    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    Archiver|手机版|小黑屋|gl-inet.cn ( 粤ICP备18130956号 )

    GMT+8, 2023-1-29 20:24 , Processed in 0.021180 second(s), 26 queries .

    Powered by Discuz! X3.4

    Copyright © 2001-2021, Tencent Cloud.

    快速回复 返回顶部 返回列表